Browse Source

Use modern LV2 includes

zrythm_meson
David Robillard 4 years ago
parent
commit
dfee534c4e
  1. 6
      sratom/sratom.h
  2. 6
      src/sratom.c
  3. 6
      tests/sratom_test.c
  4. 2
      wscript

6
sratom/sratom.h

@ -21,9 +21,9 @@ @@ -21,9 +21,9 @@
#ifndef SRATOM_SRATOM_H
#define SRATOM_SRATOM_H
#include "lv2/lv2plug.in/ns/ext/atom/atom.h"
#include "lv2/lv2plug.in/ns/ext/atom/forge.h"
#include "lv2/lv2plug.in/ns/ext/urid/urid.h"
#include "lv2/atom/atom.h"
#include "lv2/atom/forge.h"
#include "lv2/urid/urid.h"
#include "serd/serd.h"
#include "sord/sord.h"

6
src/sratom.c

@ -20,9 +20,9 @@ @@ -20,9 +20,9 @@
#include <stdlib.h>
#include <string.h>
#include "lv2/lv2plug.in/ns/ext/atom/forge.h"
#include "lv2/lv2plug.in/ns/ext/atom/util.h"
#include "lv2/lv2plug.in/ns/ext/midi/midi.h"
#include "lv2/atom/forge.h"
#include "lv2/atom/util.h"
#include "lv2/midi/midi.h"
#include "sratom/sratom.h"

6
tests/sratom_test.c

@ -19,9 +19,9 @@ @@ -19,9 +19,9 @@
#include <stdio.h>
#include <stdlib.h>
#include "lv2/lv2plug.in/ns/ext/atom/forge.h"
#include "lv2/lv2plug.in/ns/ext/atom/util.h"
#include "lv2/lv2plug.in/ns/ext/midi/midi.h"
#include "lv2/atom/forge.h"
#include "lv2/atom/util.h"
#include "lv2/midi/midi.h"
#include "sratom/sratom.h"
#define NS_RDF "http://www.w3.org/1999/02/22-rdf-syntax-ns#"

2
wscript

@ -38,7 +38,7 @@ def configure(conf): @@ -38,7 +38,7 @@ def configure(conf):
conf.fatal('Neither a shared nor a static build requested')
autowaf.check_pkg(conf, 'lv2', uselib_store='LV2',
atleast_version='1.10.0', mandatory=True)
atleast_version='1.16.0', mandatory=True)
autowaf.check_pkg(conf, 'serd-0', uselib_store='SERD',
atleast_version='0.30.0', mandatory=True)
autowaf.check_pkg(conf, 'sord-0', uselib_store='SORD',

Loading…
Cancel
Save