Browse Source

fedora: attempt gtk4 build

use_builds_script
parent
commit
5b262fe8e5
Signed by: alex
GPG Key ID: 022EAE42313D70F3
  1. 10
      rpm/zrythm.spec.in

10
rpm/zrythm.spec.in

@ -28,7 +28,7 @@ Group: Productivity/Multimedia/Sound/Editors and Convertors @@ -28,7 +28,7 @@ Group: Productivity/Multimedia/Sound/Editors and Convertors
URL: https://www.zrythm.org
Source0: https://www.zrythm.org/releases/zrythm-%{version}.tar.gz
BuildRequires: gcc-c++ gcc pkgconfig
BuildRequires: gtk3-devel >= 3.24
BuildRequires: gtk4-devel
BuildRequires: python3
BuildRequires: libcurl-devel
BuildRequires: libsndfile-devel
@ -59,12 +59,10 @@ BuildRequires: jack-devel libX11-devel update-desktop-files @@ -59,12 +59,10 @@ BuildRequires: jack-devel libX11-devel update-desktop-files
BuildRequires: fftw3-threads-devel librubberband-devel
BuildRequires: liblilv-devel
BuildRequires: guile-devel
BuildRequires: gtksourceview4-devel
Requires: gtksourceview4
Requires: jack fftw3 libfftw3_threads3 libyaml-0-2
Requires: librubberband2
#Requires: libsuil-0-0
Requires: libgtk-3-0
Requires: libgtk-4-0
Requires: guile
Requires: libsamplerate0
Requires: liblilv-0-0
@ -78,16 +76,14 @@ BuildRequires: jack-audio-connection-kit-devel libX11-devel @@ -78,16 +76,14 @@ BuildRequires: jack-audio-connection-kit-devel libX11-devel
BuildRequires: rubberband-devel
BuildRequires: lilv-devel lv2-devel
BuildRequires: guile22-devel
BuildRequires: gtksourceview3-devel
Requires: breeze-icon-theme
Requires: gtksourceview3
Requires: (jack-audio-connection-kit or pipewire-jack-audio-connection-kit)
Requires: rubberband fftw
Requires: libyaml
Requires: libsamplerate
Requires: guile22
#Requires: suil
Requires: gtk3 >= 3.24
Requires: gtk4
Requires: lilv
Requires: libsndfile
Requires: alsa-lib

Loading…
Cancel
Save